Desperatly Need An Airbag light Removing from my dash
Reply to Thread
Results 1 to 8 of 8
  1. #1

    Join Date
    Jan 2007
    Location
    Newcastle
    Posts
    6,722
    Thanks
    97
    Thanked 24 Times in 20 Posts
    jodie is offline
    As my car needs to go into the garage for an mot that its probs gunna fail i need the airbag warning light removed before doing this. Anyone that can do it in the northeast asap, will be appriecaited as otherwise its gunna hadda go into fiat.

    Cheers Guys


    With his hand buried deep inside my gammon alley, he was operating me like Kermit the Frog

    Casper a Corsa in a better outfit

    The Female Boss!

    www.builtinitaly.net
    Reply With Quote

  2. #2

    Join Date
    May 2006
    Location
    Aberdeen
    Posts
    1,966
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Ransoman is offline
    Why is it on?

    Disconnect the battery for a few hours, that might put it out.
    Driving: 2001 Alfa Romeo 147 2.0 T-Spark in Platinum Grey
    Reply With Quote

  3. #3

    Join Date
    May 2006
    Location
    SE London
    Posts
    7,054
    Thanks
    0
    Thanked 0 Times in 0 Posts
    LTG is offline
    its not an mot fail.

  4. #4

    Join Date
    Mar 2007
    Location
    LONDON
    Posts
    611
    Thanks
    0
    Thanked 0 Times in 0 Posts
    kpunto is offline
    gotta reset the ecu as far as i know. got the same problem, garage will just reset the ecu and clear the error code and it should go off- if it is connected up properly that is.

  5. #5
    Richie
    Guest

    Quote Originally Posted by LTG View Post
    its not an mot fail.
    Ditto, both of mine have been on for the last 2 years.

  6. #6

    Join Date
    May 2006
    Location
    SE London
    Posts
    7,054
    Thanks
    0
    Thanked 0 Times in 0 Posts
    LTG is offline
    Quote Originally Posted by kpunto View Post
    gotta reset the ecu as far as i know. got the same problem, garage will just reset the ecu and clear the error code and it should go off- if it is connected up properly that is.
    The airbag ecu is a seperate ecu and needs the correct tool to clear it.

    However the light will come back on anyway telling you, you have a problem.

    This will be poor electricial connection on the airbag, seat, or seatbelt pretensioner needs replacing.

    But in anycase, its not an mot fail.

  7. #7

    Join Date
    Jan 2007
    Location
    Newcastle
    Posts
    6,722
    Thanks
    97
    Thanked 24 Times in 20 Posts
    jodie is offline
    thanks lads


    With his hand buried deep inside my gammon alley, he was operating me like Kermit the Frog

    Casper a Corsa in a better outfit

    The Female Boss!

    www.builtinitaly.net
    Reply With Quote

  8. #8

    Join Date
    Mar 2007
    Location
    South East
    Posts
    1,462
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Jk. is offline
    i had problem with air bag light, was told that if you move your seats alot it tugs on the plug under them which connect the airbags, the car would instantly register a failure on the ecu as it thinks there a problem with the connection, got told wouldn't need new sensor just unplug it shove a bit of lube in then reconnect, shouldnt come on again.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
Powered by vBadvanced CMPS v4.1.0